Navicat连接服务器MySQL
创始人
2025-01-17 21:32:13
0次

Navicat连接服务器MySQL

    • 1. Navicat连接服务器MySQL
    • 2. 如何查看MySQL用户名和密码
    • 3. 修改MySQL登录密码
    • 4. 安装MySQL(Centos7)
    • 遇到错误和问题
      • 1. error 1045 (28000): access denied for user 'root'@'localhost' (using password:yes)



1. Navicat连接服务器MySQL

  1. 选择数据库
    直接使用第一个MySQL即可。我也不知道这个腾讯云版的区别在哪,我用的就是这个,表面和普通的没看出什么区别。
    在这里插入图片描述

  2. 常规设置
    在这里插入图片描述

  3. SSH设置
    设置ssh通道会使得操作数据库时,保证数据传输的安全…
    在这里插入图片描述

  4. 最终效果
    在这里插入图片描述


2. 如何查看MySQL用户名和密码

① 输入命令mysql –uroot –p,然后输入密码直接回车
② 然后再输入use mysql
③ 输入SQL语句select host,user from mysql.user;

附图:
在这里插入图片描述


3. 修改MySQL登录密码

  1. 修改my.cnf文件

    ① 输入命令vim /etc/my.cnf

    ② 然后在[mysqld]后面添加skip-grant-tables

    ③ 保存退出(Esc + :wq)

    附图:
    在这里插入图片描述

  2. 重启MySQL服务

    ① 输入命令sudo systemctl restart mysqld

  3. 选择数据库

    ① 输入命令mysql

    ② 然后再输入use mysql

    ③ 最后输入exit退出mysql

    附图:
    在这里插入图片描述

  4. 修改密码

    ① 输入命令mysql –uroot –p,不输入密码直接回车

    ② 输入SQL语句set password for root@localhost = password('自己要更改的密码');
    如果出现该错误:
    ERROR 1290 (HY000): The MySQL server is running with the --skip-grant-tables option so it cannot execute this statement
    解决方法:
    1)输入命令flush privileges;
    2)再次输入命令set password for root@localhost = password('自己要更改的密码');

    ③ 设置远程访问,输入SQL语句GRANT ALL PRIVILEGES ON *.* TO 'root'@'%' IDENTIFIED BY 'password' WITH GRANT OPTION;

    ④ 输入命令flush privileges;再次刷新

    ⑤ 最后输入exit退出mysql

    附图:
    在这里插入图片描述

  5. 还原my.cnf文件

    ① 输入命令vim /etc/my.cnf

    ② 去掉(或者注释掉)[mysqld]后面添加的skip-grant-tables

    ③ 保存退出(Esc + :wq)


4. 安装MySQL(Centos7)

repo文件是什么?
repo文件是Fedora中yum源(软件仓库)的配置文件,通常一个repo文件定义了一个或者多个软件仓库的细节内容,例如我们将从哪里下载需要安装或者升级的软件包,repo文件中的设置内容将被yum读取和应用。

  1. 下载repo文件

    [root@VM-4-2-centos ~]# wget http://repo.mysql.com/mysql-community-release-el7-5.noarch.rpm  
  2. 安装已下载的rpm包

    [root@VM-4-2-centos ~]# rpm -ivh mysql-community-release-el7-5.noarch.rpm 
  3. 安装mysql

    [root@VM-4-2-centos ~]# yum install mysql-server 
  4. 安装mysql开发包

    [root@VM-4-2-centos ~]# sudo yum install mysql-devel 

遇到错误和问题

1. error 1045 (28000): access denied for user ‘root’@‘localhost’ (using password:yes)

导致的原因:
(1) mysqld的服务器停止。重启一下MySQL服务器(systemctl restart mysqld)
(2) 用户的端口号或者IP导致错误。若用户的端口号与IP(3306/3307)不一致,打开[my.ini文件]进行编辑。全部编辑替换为port=X
(3) mysqld的配置文件错误
(4) root用户的密码错误

先看(1)和(2)解决方法,都不行直接修密码吧,大概率是密码问题。



end.

相关内容

热门资讯

解密关于开挂!德扑圈多功能真的... 解密关于开挂!德扑圈多功能真的有透视挂-一贯真的有透视1、很好的工具软件,可以解锁游戏的德扑圈辅助插...
记者爆料外挂!微扑克多功能真的... 记者爆料外挂!微扑克多功能真的有透视挂-一贯有透视1、微扑克脚本辅助下载、微扑克免费透视脚本等服务,...
重大通报辅助器!WePoKer... 重大通报辅助器!WePoKer多功能真的有透视挂-其实是有透视进入游戏-大厅左侧-新手福利-激活码辅...
安装程序教程透视挂!wpk多功... 安装程序教程透视挂!wpk多功能真的有透视挂-总是是真的有透视1)wpk有没有挂:进一步探索wpk有...
每日必看教程辅助!德扑之星多功... 每日必看教程辅助!德扑之星多功能真的有透视挂-一直是真的有透视1)德扑之星辅助插件:进一步探索德扑之...
推荐一款辅助!德普之星多功能真... 推荐一款辅助!德普之星多功能真的有透视挂-总是是有透视在进入德普之星软件靠谱后,参与本局比赛的八名玩...
实测揭晓透视器!wepoker... 实测揭晓透视器!wepoker多功能真的有透视挂-竟然是有透视1、wepoker脚本辅助下载、wep...
科技通报辅助器!德扑之星多功能... 科技通报辅助器!德扑之星多功能真的有透视挂-都是存在有透视1、进入到德扑之星是否有挂之后,能看到左侧...
每日必看教程透视挂!WePoK... 每日必看教程透视挂!WePoKer多功能真的有透视挂-切实有透视一、WePoKer可以开透视的定义与...
一分钟揭秘透视器!德扑圈多功能... 一分钟揭秘透视器!德扑圈多功能真的有透视挂-一贯存在有透视该软件可以轻松地帮助玩家将德扑圈外卦神器提...